蓝桥杯--基础训练 报时助手

报时助手(题解)

给定当前的时间,请用英文的读法将它读出来。

  时间用时h和分m表示,在英文的读法中,读一个时间的方法是:

  如果m为0,则将时读出来,然后加上“o’clock”,如3:00读作“three o’clock”。

  如果m不为0,则将时读出来,然后将分读出来,如5:30读作“five thirty”。

  时和分的读法使用的是英文数字的读法,其中0~20读作:

  0:zero, 1: one, 2:two, 3:three, 4:four, 5:five, 6:six, 7:seven, 8:eight, 9:nine, 10:ten, 11:eleven, 12:twelve, 13:thirteen, 14:fourteen, 15:fifteen, 16:sixteen, 17:seventeen, 18:eighteen, 19:nineteen, 20:twenty。

  30读作thirty,40读作forty,50读作fifty。

  对于大于20小于60的数字,首先读整十的数,然后再加上个位数。如31首先读30再加1的读法,读作“thirty one”。

  按上面的规则21:54读作“twenty one fifty four”,9:07读作“nine seven”,0:15读作“zero fifteen”。

输入格式:

输入包含两个非负整数h和m,表示时间的时和分。非零的数字前没有前导0。h小于24,m小于60。

输出格式:

输出时间时刻的英文。

样例输入:

1
0 15

输出样例:

1
zero fifteen

思路:利用哈希数组解题

我的代码如下:(AC)

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
#include <stdio.h>
char a[25][10]={"zero","one","two","three","four","five","six","seven","eight","nine","ten","eleven","twelve","thirteen",
"fourteen","fifteen","sixteen","seventeen","eighteen","nineteen","twenty"};//存储0-20
char b[6][10]={"0","0","twenty","thirty","forty","fifty"};//存储十位数
int main()
{
int h,m;
scanf("%d%d",&h,&m);
if(h>20) //大于20,分两次输出,先输出十位数,再输出个位数
printf("%s %s",a[20],a[h-20]);
else //小于20直接哈希定位
printf("%s",a[h]);
if(m==0) //分钟数为0,直接输出o'clock
printf(" o'clock");
else //否则先输出空格
{
printf(" ");
if(m>20)//大于20,分两次输出,先输出十位数,再输出个位数
{
int temp=m%10;
if(temp==0) //如果个位数为0,仅输出十位
printf("%s",b[m/10]);
else //否则输出十位
printf("%s %s",b[m/10],a[temp]);
}
else //小于20直接哈希定位
printf("%s",a[m]);
}
return 0;
}
小礼物走一个哟
0%